, , ,

Plesk' de PHP Extension Aktif Etmek

Plesk hosting paketlerimizde sunucu yoğunluğunu uygun seviyede tutabilmek adına bazı bileşenleri ilk hosting açılışı esnasında pasif olarak sunmaktayız. Kullanmış olduğunuz yazılımlar tarafından gerekli bulunması halinde PHP bileşenlerini Plesk üzerinden aktif edebilmektesiniz.

Aşağıdaki örneğimizde "zip" bileşenini aktif etmek anlatılmıştır, aynı şekilde diğer ihtiyacınız olan bileşenleride işaretleyerek aktif edebilmektesiniz.

1) Cloud panele giriş yapınız.

Müşteri panelinizde sol bölümde bulunan "Hosting Yönetimi" menüsüne tıklayınız ve açılan sayfadan hesap adınızı seçerek "Detaylar" butonuna tıklayınız. Sayfanın orta kısımlarında "Kontrol Paneli" ikonu göreceksiniz, tıklayarak cloud hosting kontrol panelinize giriş yapabilirsiniz.

2) Cloud panel erişimi sonrasında "Web Sitesi Yönetimi" menüsüne tıklayınız, alan adınızın yanında bulunan "Yönet" butonuna tıklayınız ve ardından "Plesk' e Bağlan" linkine tıklayınız.

3) Aşağıda bulunan görselde yeşil kutu içerisine alınmış menüye tıklayınız.

Screenshot_3

4) PHP sürümü seçili değil ise, yazılımınıza uygun PHP sürümünü seçerek "Set at current" butonuna tıklayınız, sağ alt bölümde bulunan "zip" alanını işaretleyiniz ve "Save" butonuna tıklayınız.

Screenshot_4

Sık kullanılan PHP bileşenlerinden bahsetmek gerekirse;

ioncube_loader
Ioncube bir yazılım şifreleme uygulamasıdır, bu uygulama ile; hazırlanan PHP scriptin kodları değiştilerek okunaksız bir hale getirilir. ioncube_loader PHP bileşeni ise bu kodları okuyarak scriptin sağlıklı bir şekilde çalışmasını sağlar. Genellikle WordPress' in lisanslı temalarında ioncube_loader bileşenine sıklıkla ihtiyaç duyulmaktadır.

mcrypt
Ioncube' a benzer bir mantıkta çalışan, cookies şifreleme amacı ile kullanılan bir uygulamadır. Bu şifrelerin okunabilmesi için ise PHP mcrypt bileşeninin aktif olması gerekmektedir. Genellikle Magento, Prestashop gibi e-ticaret yazılımları tarafından sıkça kullanılmaktadır.

mysqli
PHP yazılımının veritabanı bağlantısı ile ilgili bir durumdur, eğer veritabanı bağlantılarında mysqli yapısı kullanılıyor ise mysqli bileşeni aktif edilmelidir. mysqli kullanılabilmesi için bu bileşenin aktif edilmesi yeterli değildir. Aynı zamanda MySQL sunucusunun sürümü 4.1 ve üzeri olmalıdır.

pdo
PHP 5.1.0 sürümü üzerinde çalışabilen, mysql ve mysqli gibi veritabanı bağlantı ve işlemleri gerçekleştiren bir yapıdır. mysql bağlantılarına oranla daha güvenli ve hızlıdır. Son yıllarda geliştirilen birçok özel yazılım tarafından pdo bileşeninin aktif olması talep edilmektedir.

zip
Sıkıştırılmış arşiv dosyalarını kolayca okuma ve yazma imkanı sağlayan bir PHP bileşenidir, genellikle WordPress ve Prestashop yazılımlarında bu bileşene ihtiyaç duyulmaktadır.

 

Bu Konuyu Faydalı Buldunuz Mu?

0 Değerlendirme
Upvote Downvote

Total votes: 0

Upvotes: 0

Upvotes percentage: 0.000000%

Downvotes: 0

Downvotes percentage: 0.000000%

2 Yorum Mevcut

Bu Konuda Bir Yorum Yazın

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

KOBİ 'lere Hosting Yönetiminde Tavsiyeler

Sitem Çalışmıyor! Ne Yapmalıyım?